Autonomía digital y tecnológica

Código e ideas para una internet distribuida

Repositorio para el plugin de flash: cómo tenerlo siempre actualizados en Debian

Imago voragine.net
[actualizado el ]

Para instalar el plugin de flash y que funcione en todos los navegadores que tengas instalados en tu Debian lo mejor es añadir un repositorio que lo contenga. Así la instalación y las actualizaciones se realiza a través de un gestor de paquetes, como apt o aptitude.

Se puede usar por ejemplo backports.org, que lo incluye o también debian-multimedia.org. Al no ser repositorios oficiales, una vez añadidos a nuestra lista de repositorios, debemos autentificarlos instalando el paquete con su clave. Una vez hecho esto podremos instalar cualquier paquete del repositorio. Los siguintes comandos debemos ejecutarlos como superusuario root.

Añadimos el repositorio a la lista:
#echo "deb http://www.backports.org/debian etch-backports
main contrib non-free" >> /etc/apt/sources.list

Autentificamos el nuevo repositorio:
#apt-get install debian-backports-keyring

Actualizamos la lista de paquetes e instalamos el paquete deseado:
#apt-get update; apt-get install flashplugin-nonfree

Reiniciamos el navegador, o lo abrimos, y deberíamos poder ver el contenido flash de las páginas. Puede ocurrir que si hemos instalado un navegador manualmente, sin la ayuda de un gestor de paquetes, la instalación o actualización no le afecte. Esto es porque el instalador del plugin no ha encontrado ese navegador; para solucionarlo ayudamos al navegador a llegar hasta el nuevo plugin mediante una liga blanda, un enlace, a la ubicación del plugin. La liga blanda debemos crearla en el lugar adecuado, generalmente el directorio plugins/ dentro de la carpeta donde esté instalado el navegador; y debe apuntar a l lugar donde esté instalado el plugin. El siguiente comando lo ejecutaremos como usuario normal, no como root:

Hacemos un liga blanda (en mi caso para firefox 3 y con el plugin de backports.org):
ln -s /usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/local/bin/firefox/plugins/libflashplayer.so

Fuente: Debian Admin.

2 comentarios

    • Por daniel

    alert();

    • Por Josep •

    Gracias por la información. He tenido que hacer algo similar pero para lenny amd64.
    Entre la edición de /etc/apt/sources.list y la instalación del anillo de claves (keyring) tuve que hacer un “apt-get update” adicional, y en la instalación del anillo (apt-get install debian-backports-keyring) decirle expresamente que quería instalar sin verificar… claro, como es el paquete con las claves… pues aún no las tiene ;)

    Saludos, Josep

Dejar un comentario

*
*

 

No hay trackbacks